summaryrefslogtreecommitdiffstats
path: root/gst/shapewipe/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/shapewipe/Makefile.am')
-rw-r--r--gst/shapewipe/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/gst/shapewipe/Makefile.am b/gst/shapewipe/Makefile.am
new file mode 100644
index 00000000..7f6df372
--- /dev/null
+++ b/gst/shapewipe/Makefile.am
@@ -0,0 +1,11 @@
+plugin_LTLIBRARIES = libgstshapewipe.la
+
+libgstshapewipe_la_SOURCES = gstshapewipe.c
+
+libgstshapewipe_la_CFLAGS = $(GIO_CFLAGS) $(GST_CFLAGS) $(GST_CONTROLLER_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstshapewipe_la_LIBADD = $(GIO_LIBS) $(GST_LIBS) $(GST_CONTROLLER_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@
+libgstshapewipe_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstshapewipe_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstshapewipe.h
+