summaryrefslogtreecommitdiffstats
path: root/gst/siren/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/siren/Makefile.am')
-rw-r--r--gst/siren/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/gst/siren/Makefile.am b/gst/siren/Makefile.am
new file mode 100644
index 00000000..9ecefd02
--- /dev/null
+++ b/gst/siren/Makefile.am
@@ -0,0 +1,16 @@
+plugin_LTLIBRARIES = libgstsiren.la
+
+libgstsiren_la_SOURCES = gstsiren.c \
+ gstsirendec.c gstsirendec.h \
+ gstsirenenc.c gstsirenenc.h \
+ gstrtpsirenpay.c gstrtpsirenpay.h \
+ gstrtpsirendepay.c gstrtpsirendepay.h \
+ common.c dct4.c decoder.c encoder.c huffman.c \
+ huffman.h rmlt.h common.h dct4.h decoder.h \
+ encoder.h huffman_consts.h rmlt.c siren7.h
+
+
+libgstsiren_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(ERROR_CFLAGS)
+libgstsiren_la_LIBADD = $(GST_LIBS_LIBS) $(GST_BASE_LIBS) \
+ -lgstrtp-@GST_MAJORMINOR@
+libgstsiren_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)