summaryrefslogtreecommitdiffstats
path: root/src/libs/engine/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-10-22 03:48:28 +0000
committerDavid Robillard <d@drobilla.net>2007-10-22 03:48:28 +0000
commite9d99340c9ac29aaa7912db0554a88820c4a776a (patch)
tree2bb49de8b90d861330e8db50919a8137b10cc913 /src/libs/engine/Makefile.am
parent5ae4d4d5e805e828b51b98767ac51da24c3b21f1 (diff)
downloadingen-e9d99340c9ac29aaa7912db0554a88820c4a776a.tar.gz
ingen-e9d99340c9ac29aaa7912db0554a88820c4a776a.tar.bz2
ingen-e9d99340c9ac29aaa7912db0554a88820c4a776a.zip
Rework plugin design (engine side) to be less crap.
Use LADSPA labels instead of munged friendly names to generate OSC paths. Separate OSC paths/names from human friendly names (conceptually, still needs UI exposing). git-svn-id: http://svn.drobilla.net/lad/ingen@898 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/libs/engine/Makefile.am')
-rw-r--r--src/libs/engine/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/libs/engine/Makefile.am b/src/libs/engine/Makefile.am
index 91af96fc..bbc621ae 100644
--- a/src/libs/engine/Makefile.am
+++ b/src/libs/engine/Makefile.am
@@ -29,9 +29,9 @@ libingen_engine_la_SOURCES = \
BufferFactory.hpp \
ClientBroadcaster.cpp \
ClientBroadcaster.hpp \
+ CompiledPatch.hpp \
ConnectionImpl.cpp \
ConnectionImpl.hpp \
- CompiledPatch.hpp \
Driver.hpp \
DuplexPort.cpp \
DuplexPort.hpp \
@@ -46,10 +46,16 @@ libingen_engine_la_SOURCES = \
GraphObjectImpl.hpp \
InputPort.cpp \
InputPort.hpp \
+ InternalPlugin.cpp \
+ InternalPlugin.hpp \
JackAudioDriver.cpp \
JackAudioDriver.hpp \
JackMidiDriver.cpp \
JackMidiDriver.hpp \
+ LADSPAPlugin.cpp \
+ LADSPAPlugin.hpp \
+ LV2Plugin.cpp \
+ LV2Plugin.hpp \
MidiBuffer.cpp \
MidiBuffer.hpp \
MidiControlNode.cpp \
@@ -71,7 +77,6 @@ libingen_engine_la_SOURCES = \
OSCDriver.hpp \
OSCEngineReceiver.cpp \
OSCEngineReceiver.hpp \
- Responder.hpp \
ObjectSender.cpp \
ObjectSender.hpp \
ObjectStore.cpp \
@@ -80,22 +85,24 @@ libingen_engine_la_SOURCES = \
OutputPort.hpp \
PatchImpl.cpp \
PatchImpl.hpp \
+ PatchPlugin.hpp \
PluginImpl.cpp \
PluginImpl.hpp \
PortImpl.cpp \
PortImpl.hpp \
PostProcessor.cpp \
PostProcessor.hpp \
- ProcessContext.hpp \
ProcessContext.cpp \
- ProcessSlave.hpp \
+ ProcessContext.hpp \
ProcessSlave.cpp \
+ ProcessSlave.hpp \
QueuedEngineInterface.cpp \
QueuedEngineInterface.hpp \
QueuedEvent.cpp \
QueuedEvent.hpp \
QueuedEventSource.cpp \
QueuedEventSource.hpp \
+ Responder.hpp \
ThreadManager.hpp \
TransportNode.cpp \
TransportNode.hpp \