summaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/meson.build b/tools/meson.build
index ee35378..199f7d7 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -18,6 +18,7 @@ foreach tool : basic_tools
files(tool + '.c'),
c_args: c_suppressions,
dependencies: lilv_dep,
+ implicit_include_directories: false,
install: true,
)
@@ -38,8 +39,9 @@ install_data(
sndfile_dep = dependency(
'sndfile',
- version: '>= 1.0.0',
+ include_type: 'system',
required: get_option('tools'),
+ version: '>= 1.0.0',
)
if sndfile_dep.found()
@@ -48,6 +50,7 @@ if sndfile_dep.found()
files('lv2apply.c'),
c_args: c_suppressions,
dependencies: [lilv_dep, sndfile_dep],
+ implicit_include_directories: false,
install: true,
)
@@ -78,6 +81,7 @@ int main(void) { struct timespec t; return clock_gettime(CLOCK_MONOTONIC, &t); }
files('lv2bench.c'),
c_args: c_suppressions,
dependencies: [lilv_dep, rt_dep, sndfile_dep],
+ implicit_include_directories: false,
install: true,
)