aboutsummaryrefslogtreecommitdiffstats
path: root/src/engine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/engine/Makefile.am')
-rw-r--r--src/engine/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/engine/Makefile.am b/src/engine/Makefile.am
index e79502e..ccfae64 100644
--- a/src/engine/Makefile.am
+++ b/src/engine/Makefile.am
@@ -10,7 +10,6 @@ libmachina_la_SOURCES = \
ActionFactory.cpp \
Edge.cpp \
Engine.cpp \
- Evolver.cpp \
LearnRequest.cpp \
Loader.cpp \
Machine.cpp \
@@ -18,10 +17,13 @@ libmachina_la_SOURCES = \
MidiAction.cpp \
Mutation.cpp \
Node.cpp \
- Problem.cpp \
Recorder.cpp \
SMFDriver.cpp
if WITH_JACK
-libmachina_la_SOURCES += JackDriver.cpp jack_compat.h
+libmachina_la_SOURCES += JackDriver.cpp
+endif
+
+if WITH_EUGENE
+libmachina_la_SOURCES += Evolver.cpp Problem.cpp
endif