summaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-19 09:54:48 -0400
committerDavid Robillard <d@drobilla.net>2022-07-20 10:35:05 -0400
commitc0ef025450cf1b7eec85ae8058e0a9e301e7cd16 (patch)
tree6914ea1a19f3cf656533b902cf823c4953bce5cb /meson/suppressions/meson.build
parent4f33eb5ba4e2c116b9413282e18508815ea73966 (diff)
downloadpatchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.tar.gz
patchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.tar.bz2
patchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.zip
Switch to meson build system
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build71
1 files changed, 71 insertions, 0 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
new file mode 100644
index 0000000..ea5d66e
--- /dev/null
+++ b/meson/suppressions/meson.build
@@ -0,0 +1,71 @@
+# Copyright 2020-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR GPL-3.0-or-later
+
+# Project-specific warning suppressions.
+#
+# This should be used in conjunction with the generic "warnings" sibling that
+# enables all reasonable warnings for the compiler. It lives here just to keep
+# the top-level meson.build more readable.
+
+#######
+# C++ #
+#######
+
+if is_variable('cpp')
+ cpp_suppressions = []
+
+ if get_option('strict')
+ if cpp.get_id() == 'clang'
+ cpp_suppressions += [
+ '-Wno-alloca',
+ '-Wno-cast-qual',
+ '-Wno-double-promotion',
+ '-Wno-float-conversion',
+ '-Wno-float-equal',
+ '-Wno-implicit-float-conversion',
+ '-Wno-padded',
+ '-Wno-pedantic',
+ '-Wno-shorten-64-to-32',
+ '-Wno-sign-conversion',
+ '-Wno-weak-vtables',
+ ]
+
+ if host_machine.system() == 'darwin'
+ cpp_suppressions += [
+ '-Wno-documentation', # JACK
+ '-Wno-documentation-deprecated-sync', # JACK
+ '-Wno-documentation-unknown-command', # boost
+ '-Wno-global-constructors', # boost
+ '-Wno-old-style-cast', # boost
+ '-Wno-redundant-parens', # boost
+ '-Wno-reserved-id-macro', # boost
+ '-Wno-zero-as-null-pointer-constant', # boost
+ ]
+ endif
+
+ elif cpp.get_id() == 'gcc'
+ cpp_suppressions += [
+ '-Wno-abi-tag',
+ '-Wno-alloca',
+ '-Wno-conditionally-supported',
+ '-Wno-conversion',
+ '-Wno-effc++',
+ '-Wno-float-equal',
+ '-Wno-inline',
+ '-Wno-null-dereference',
+ '-Wno-padded',
+ '-Wno-pedantic',
+ '-Wno-stack-protector',
+ '-Wno-strict-overflow',
+ '-Wno-suggest-attribute=const',
+ '-Wno-suggest-attribute=noreturn',
+ '-Wno-suggest-attribute=pure',
+ '-Wno-suggest-final-methods',
+ '-Wno-suggest-final-types',
+ '-Wno-switch-default',
+ ]
+ endif
+ endif
+
+ cpp_suppressions = cpp.get_supported_arguments(cpp_suppressions)
+endif