summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-06-09 02:18:57 +0000
committerDavid Robillard <d@drobilla.net>2006-06-09 02:18:57 +0000
commit2f0e092964f800c0ff82cbd08bf2ee05db814e7b (patch)
treed35a09dc50535aae9292f8ca3262adc5526fe2a6 /src/Makefile.am
downloadpatchage-2f0e092964f800c0ff82cbd08bf2ee05db814e7b.tar.gz
patchage-2f0e092964f800c0ff82cbd08bf2ee05db814e7b.tar.bz2
patchage-2f0e092964f800c0ff82cbd08bf2ee05db814e7b.zip
Added patchage
git-svn-id: http://svn.drobilla.net/lad/patchage@5 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..6e6eb5f
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+AM_CXXFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\" @LIBGLADEMM_CFLAGS@ @GNOMECANVASMM_CFLAGS@ @JACK_CFLAGS@ @ALSA_CFLAGS@ @LASH_CFLAGS@ @FLOWCANVAS_CFLAGS@
+patchage_LDADD = @LIBGLADEMM_LIBS@ @GNOMECANVASMM_LIBS@ @JACK_LIBS@ @ALSA_LIBS@ @LASH_LIBS@ @FLOWCANVAS_LIBS@
+
+EXTRA_DIST = patchage.gladep
+
+sharefilesdir = $(pkgdatadir)
+dist_sharefiles_DATA = patchage.glade
+
+bin_PROGRAMS = patchage
+patchage_SOURCES = \
+ main.cpp \
+ Patchage.h \
+ Patchage.cpp \
+ StateManager.h \
+ StateManager.cpp \
+ PatchageModule.h \
+ PatchagePort.h \
+ JackDriver.h \
+ JackDriver.cpp \
+ AlsaDriver.h \
+ AlsaDriver.cpp \
+ PatchageFlowCanvas.h \
+ PatchageFlowCanvas.cpp
+
+if WITH_LASH
+patchage_SOURCES += LashDriver.h LashDriver.cpp
+endif