summaryrefslogtreecommitdiffstats
path: root/lint/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lint/meson.build')
-rw-r--r--lint/meson.build47
1 files changed, 47 insertions, 0 deletions
diff --git a/lint/meson.build b/lint/meson.build
new file mode 100644
index 0000000..48e736d
--- /dev/null
+++ b/lint/meson.build
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR GPL-3.0-or-later
+
+if not meson.is_subproject()
+ # Check release metadata
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test(
+ 'autoship',
+ autoship,
+ args: ['test', patchage_src_root],
+ suite: 'data',
+ )
+ endif
+
+ # Check code with cppcheck
+ cppcheck = find_program('cppcheck', required: false)
+ if cppcheck.found()
+ compdb_path = join_paths(patchage_build_root, 'compile_commands.json')
+ suppress_path = join_paths(patchage_src_root, '.suppress.cppcheck')
+ test(
+ 'cppcheck',
+ cppcheck,
+ args: [
+ '--enable=warning,style,performance,portability',
+ '--error-exitcode=1',
+ '--project=' + compdb_path,
+ '--suppressions-list=' + suppress_path,
+ '-DPATCHAGE_DISABLE_FMT_WARNINGS=',
+ '-q',
+ ],
+ suite: 'code',
+ timeout: 60,
+ )
+ endif
+endif
+
+# Check licensing metadata
+reuse = find_program('reuse', required: false)
+if reuse.found()
+ test(
+ 'REUSE',
+ reuse,
+ args: ['--root', patchage_src_root, 'lint'],
+ suite: 'data',
+ )
+endif