summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build44
1 files changed, 1 insertions, 43 deletions
diff --git a/meson.build b/meson.build
index 6eb66ca..93cf950 100644
--- a/meson.build
+++ b/meson.build
@@ -316,49 +316,7 @@ install_man(files('doc/patchage.1'))
#########
if get_option('lint')
- if not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test(
- 'autoship',
- autoship,
- args: ['test', patchage_src_root],
- suite: 'data',
- )
- endif
-
- # Check code with cppcheck
- cppcheck = find_program('cppcheck', required: false)
- if cppcheck.found()
- compdb_path = join_paths(patchage_build_root, 'compile_commands.json')
- suppress_path = join_paths(patchage_src_root, '.suppress.cppcheck')
- test(
- 'cppcheck',
- cppcheck,
- args: [
- '--enable=warning,style,performance,portability',
- '--error-exitcode=1',
- '--project=' + compdb_path,
- '--suppressions-list=' + suppress_path,
- '-q',
- ],
- suite: 'code',
- timeout: 60,
- )
- endif
- endif
-
- # Check licensing metadata
- reuse = find_program('reuse', required: false)
- if reuse.found()
- test(
- 'REUSE',
- reuse,
- args: ['--root', patchage_src_root, 'lint'],
- suite: 'data',
- )
- endif
+ subdir('lint')
endif
if not meson.is_subproject()