aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-11-24 11:44:02 -0500
committerDavid Robillard <d@drobilla.net>2022-11-24 11:44:02 -0500
commit88d6a4572aa136704881e4fdeeecf8bba03e49ea (patch)
treeeb290beb7439365a96a71213a784a20491056070 /doc/meson.build
parentd979edba4cc9d04f930d6290bee9404016fcce10 (diff)
downloadpugl-88d6a4572aa136704881e4fdeeecf8bba03e49ea.tar.gz
pugl-88d6a4572aa136704881e4fdeeecf8bba03e49ea.tar.bz2
pugl-88d6a4572aa136704881e4fdeeecf8bba03e49ea.zip
Add docs_cpp configuration option and disable it by default
Doxygen is now giving parse errors in most places where @copydoc is used. Unfortunately, this setup for bindings with documentation is generally really flaky, and I probably need to figure something else out anyway.
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 511316d..66456b7 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -12,5 +12,8 @@ build_docs = doxygen.found() and sphinx_build.found()
if build_docs
subdir('_static')
subdir('c')
- subdir('cpp')
+
+ if not get_option('docs_cpp').disabled()
+ subdir('cpp')
+ endif
endif