aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-01-12 15:30:44 -0500
committerDavid Robillard <d@drobilla.net>2023-01-14 11:53:28 -0500
commit1e48f8bbfdb0f1ce2f9132d604405fb72d160d9d (patch)
tree2fbb2e70f5bf5e7f7e021dafb51dd508944426f2 /meson.build
parentbd4f79646f623e929e6aa22bea028952b515aeef (diff)
downloadpugl-1e48f8bbfdb0f1ce2f9132d604405fb72d160d9d.tar.gz
pugl-1e48f8bbfdb0f1ce2f9132d604405fb72d160d9d.tar.bz2
pugl-1e48f8bbfdb0f1ce2f9132d604405fb72d160d9d.zip
Windows: Add PUGL_DARK_FRAME hint
This allows dark applications to visually integrate more nicely in Windows 10. A little thing, but it really goes a long way to make programs not look out of place and half-baked.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 652cd77..63f14bb 100644
--- a/meson.build
+++ b/meson.build
@@ -99,10 +99,11 @@ elif host_machine.system() == 'windows'
user32_dep = cc.find_library('user32')
shlwapi_dep = cc.find_library('shlwapi')
+ dwmapi_dep = cc.find_library('dwmapi')
platform = 'win'
platform_sources = files('src/win.c')
- core_deps = [user32_dep, shlwapi_dep]
+ core_deps = [user32_dep, shlwapi_dep, dwmapi_dep]
extension = '.c'
else # X11