aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-03 10:08:00 -0400
committerDavid Robillard <d@drobilla.net>2023-05-03 10:14:00 -0400
commitaca5c2512c94b605f3360bea364553e569b72616 (patch)
tree78fe285cca1ab73b654124ea5784d773307d19fc /meson.build
parente6b135279a6389c1a1e7df31f7ae9795bd0cd0af (diff)
downloadpugl-aca5c2512c94b605f3360bea364553e569b72616.tar.gz
pugl-aca5c2512c94b605f3360bea364553e569b72616.tar.bz2
pugl-aca5c2512c94b605f3360bea364553e569b72616.zip
Use consistent meson formatting everywhere
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 17 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 6185fde..0255079 100644
--- a/meson.build
+++ b/meson.build
@@ -1,16 +1,19 @@
# Copyright 2021-2023 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-project('pugl', ['c'],
- version: '0.5.3',
- license: 'ISC',
- meson_version: '>= 0.54.0',
- default_options: [
- 'b_ndebug=if-release',
- 'buildtype=release',
- 'c_std=c99',
- 'cpp_std=c++14',
- ])
+project(
+ 'pugl',
+ ['c'],
+ default_options: [
+ 'b_ndebug=if-release',
+ 'buildtype=release',
+ 'c_std=c99',
+ 'cpp_std=c++14',
+ ],
+ license: 'ISC',
+ meson_version: '>= 0.54.0',
+ version: '0.5.3',
+)
pugl_src_root = meson.current_source_dir()
major_version = meson.project_version().split('.')[0]
@@ -45,8 +48,10 @@ if get_option('strict')
endif
# Disable deprecated API which is not used by tests or examples
-add_project_arguments(['-DPUGL_DISABLE_DEPRECATED'],
- language: ['c', 'cpp', 'objc', 'objcpp'])
+add_project_arguments(
+ ['-DPUGL_DISABLE_DEPRECATED'],
+ language: ['c', 'cpp', 'objc', 'objcpp'],
+)
#############
# Platforms #