aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-01-07 17:46:36 -0500
committerDavid Robillard <d@drobilla.net>2023-01-07 19:26:29 -0500
commitb6ecd23cfb3c82c2c3f05795ebd9c65314e6367c (patch)
tree61a557e16d92a9cfdf9a8460ae960dc8c972b32c /meson.build
parentf8802f31089656379f056eb390c0d38484589136 (diff)
downloadpugl-b6ecd23cfb3c82c2c3f05795ebd9c65314e6367c.tar.gz
pugl-b6ecd23cfb3c82c2c3f05795ebd9c65314e6367c.tar.bz2
pugl-b6ecd23cfb3c82c2c3f05795ebd9c65314e6367c.zip
MacOS: Consistently use the same flags for ObjC and ObjC++
The implementation only uses ObjC, but this is mistake-prone, it's better to just have things set up properly for all of the languages that are present in the build at all.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 4e04012..63e9e13 100644
--- a/meson.build
+++ b/meson.build
@@ -34,7 +34,7 @@ endif
# Enable Objective C support if we're building for MacOS
if host_machine.system() == 'darwin'
- add_languages(['objc'], native: false)
+ add_languages(['objc', 'objcpp'], native: false)
objcc = meson.get_compiler('objc')
endif
@@ -46,7 +46,7 @@ endif
# Disable deprecated API which is not used by tests or examples
add_project_arguments(['-DPUGL_DISABLE_DEPRECATED'],
- language: ['c', 'cpp', 'objc'])
+ language: ['c', 'cpp', 'objc', 'objcpp'])
#############
# Platforms #
@@ -155,7 +155,10 @@ library_args = ['-DPUGL_INTERNAL']
subdir('meson/library')
if library_type == 'static_library'
- add_project_arguments(['-DPUGL_STATIC'], language: ['c', 'cpp', 'objc'])
+ add_project_arguments(
+ ['-DPUGL_STATIC'],
+ language: ['c', 'cpp', 'objc', 'objcpp'],
+ )
endif
common_sources = files(