aboutsummaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-10-30 18:44:35 -0400
committerDavid Robillard <d@drobilla.net>2022-10-30 18:46:24 -0400
commitb30d8f984cd2744d06044c28b6a76399e3634e00 (patch)
treed9c93c4338aa78adf8e259e79b7b96b66a2759cb /meson/suppressions/meson.build
parentdecde99974f4d879329837d2f8ceb6a556895127 (diff)
downloadpugl-b30d8f984cd2744d06044c28b6a76399e3634e00.tar.gz
pugl-b30d8f984cd2744d06044c28b6a76399e3634e00.tar.bz2
pugl-b30d8f984cd2744d06044c28b6a76399e3634e00.zip
Add malloc attributes to allocating functions
These inform the compiler that the returned value doesn't alias with anything. Also somewhat handy as pseudo-documentation.
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index ffc6595..1cbdb99 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -40,7 +40,6 @@ elif cc.get_id() == 'gcc'
'-Wno-padded',
'-Wno-pedantic',
'-Wno-suggest-attribute=const',
- '-Wno-suggest-attribute=malloc',
'-Wno-suggest-attribute=pure',
'-Wno-switch-default',
'-Wno-switch-enum',