aboutsummaryrefslogtreecommitdiffstats
path: root/examples/pugl_shader_demo.app/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/pugl_shader_demo.app/meson.build')
-rw-r--r--examples/pugl_shader_demo.app/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/pugl_shader_demo.app/meson.build b/examples/pugl_shader_demo.app/meson.build
new file mode 100644
index 0000000..82b4a34
--- /dev/null
+++ b/examples/pugl_shader_demo.app/meson.build
@@ -0,0 +1,21 @@
+config = configuration_data()
+config.set('NAME', 'pugl_shader_demo')
+
+info_plist = configure_file(configuration: config,
+ input: files('../../resources/Info.plist.in'),
+ output: 'Info.plist')
+
+shaders = [
+ 'header_330.glsl',
+ 'header_420.glsl',
+ 'rect.vert',
+ 'rect.frag',
+]
+
+foreach shader : shaders
+ configure_file(input: files('..' / 'shaders' / shader),
+ output: shader,
+ copy: true)
+endforeach
+
+subdir('MacOS')