aboutsummaryrefslogtreecommitdiffstats
path: root/examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build')
-rw-r--r--examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build b/examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build
new file mode 100644
index 0000000..2ff4e87
--- /dev/null
+++ b/examples/pugl_vulkan_cpp_demo.app/MacOS/meson.build
@@ -0,0 +1,10 @@
+executable(
+ 'pugl_vulkan_cpp_demo',
+ [
+ '../../pugl_vulkan_cpp_demo.cpp',
+ '../../file_utils.c',
+ ],
+ include_directories: include_directories('../../../../include', '../../..'),
+ c_args: example_defines + example_c_args,
+ cpp_args: example_defines + example_cpp_args,
+ dependencies: [puglpp_dep, vulkan_backend_dep])