summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-04-06 02:20:48 +0000
committerDavid Robillard <d@drobilla.net>2007-04-06 02:20:48 +0000
commit15499616e93c99ed9836461e0ef4b1b76ad8933d (patch)
treeedf4f44bdf5832e7041f8a26c6c02ad3074470ea /configure.ac
parent7919a0a3a9f10d4cf60f8c8cf20840631e82c447 (diff)
downloadraul-15499616e93c99ed9836461e0ef4b1b76ad8933d.tar.gz
raul-15499616e93c99ed9836461e0ef4b1b76ad8933d.tar.bz2
raul-15499616e93c99ed9836461e0ef4b1b76ad8933d.zip
LASH project saving/restoring.
git-svn-id: http://svn.drobilla.net/lad/raul@400 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 62f93af..e567dbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,22 @@ if test "$build_liblo" = "yes"; then
fi
AM_CONDITIONAL(WITH_LIBLO, [test "$build_liblo" = "yes"])
+build_lash="yes"
+AC_ARG_ENABLE(lash,
+ [AS_HELP_STRING(--enable-lash, [Enable LASH session management support (yes)])],
+ [ if test x$enable_lash = xno ; then build_lash=no ; fi ])
+if test "$build_lash" = "yes"; then
+ PKG_CHECK_MODULES(LASH, lash-1.0 >= 0.5.0, have_lash="yes", have_lash="no")
+ if test "$have_lash" = "yes"; then
+ AC_DEFINE(HAVE_LASH, 1, [Has lash.h])
+ else
+ AC_MSG_WARN([LASH not found, session support will not be built.])
+ build_lash="no"
+ fi
+fi
+AM_CONDITIONAL(WITH_LASH, [test "$build_lash" = "yes"])
+
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([src/Makefile])
AC_CONFIG_FILES([raul/Makefile])
@@ -128,10 +144,11 @@ AC_MSG_RESULT([Raul build configuration:])
AC_MSG_RESULT([])
AC_MSG_RESULT([Building unit tests: $build_unit_tests])
AC_MSG_RESULT([])
+AC_MSG_RESULT([Jack support: $build_jack])
+AC_MSG_RESULT([LASH support: $build_lash])
AC_MSG_RESULT([OSC (Liblo) support: $build_liblo])
AC_MSG_RESULT([RDF Serialization (Raptor) support: $build_raptor])
AC_MSG_RESULT([RDF Querying (Rasqal) support: $build_rasqal])
-AC_MSG_RESULT([Jack support: $build_jack])
AC_MSG_RESULT([Smart Pointers (Boost): $build_smart_pointers])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([])