summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-10-16 07:28:30 +0000
committerDavid Robillard <d@drobilla.net>2006-10-16 07:28:30 +0000
commit4e68bf298f9fe4445925b4fe39f28e364a216fd2 (patch)
tree199cf1eb30a32554cffd5f5aa1ac26ad7bf89dba /configure.ac
parente22d5e4bfa4e5de0cba97c0e1a4ea71de9ecbe48 (diff)
downloadraul-4e68bf298f9fe4445925b4fe39f28e364a216fd2.tar.gz
raul-4e68bf298f9fe4445925b4fe39f28e364a216fd2.tar.bz2
raul-4e68bf298f9fe4445925b4fe39f28e364a216fd2.zip
Used boost::noncopyable to eliminate undefined private copy constructors spread everywhere.
git-svn-id: http://svn.drobilla.net/lad/raul@182 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7c12a2..635c127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,9 @@ if test "$build_smart_pointers" = "yes"; then
AC_CHECK_HEADER([boost/weak_ptr.hpp], [],
AC_MSG_ERROR([You need the boost headers package (e.g. libboost-dev)]))
+
+ AC_CHECK_HEADER([boost/utility.hpp], [],
+ AC_MSG_ERROR([You need the boost headers package (e.g. libboost-dev)]))
AC_SUBST(BOOST_CFLAGS)
AC_SUBST(BOOST_LIBS)