summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-01-20 02:35:34 +0000
committerDavid Robillard <d@drobilla.net>2007-01-20 02:35:34 +0000
commitca32b189529ffc7c1d42af85f005dea54189218f (patch)
tree38d1d4cc4dee419b6fe1e717fc1e4f2f08ea46d5 /configure.ac
parent2472d92b7d8e11fa3e09437515000763717b10d3 (diff)
downloadraul-ca32b189529ffc7c1d42af85f005dea54189218f.tar.gz
raul-ca32b189529ffc7c1d42af85f005dea54189218f.tar.bz2
raul-ca32b189529ffc7c1d42af85f005dea54189218f.zip
Added Machina.
Moved some Jack and RDF functionality down to RAUL from Ingen, for use by Machina. git-svn-id: http://svn.drobilla.net/lad/raul@263 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 26 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c0eaf8c..06d3560 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,6 +50,9 @@ AC_ARG_ENABLE(unit-tests,
[build_unit_tests="$enableval"])
AM_CONDITIONAL(BUILD_TESTS, [test "$build_unit_tests" = "yes"])
+# Check for glibmm
+PKG_CHECK_MODULES(GLIBMM, glibmm-2.4)
+
build_smart_pointers="yes"
AC_ARG_ENABLE(smart_pointers,
[AS_HELP_STRING(--enable-smart_pointers, [Include smart pointers - requires boost (yes)])],
@@ -69,6 +72,15 @@ if test "$build_smart_pointers" = "yes"; then
fi
AM_CONDITIONAL(WITH_BOOST, [test "$build_smart_pointers" = "yes"])
+build_jack="yes"
+AC_ARG_ENABLE(jack,
+ [AS_HELP_STRING(--enable-jack, [Include JACK audio/midi support (yes)])],
+ [ if test x$enable_jack = xno ; then build_jack=no ; fi ])
+if test "$build_jack" = "yes"; then
+ PKG_CHECK_MODULES(JACK, jack >= 0.102.20, [],
+ AC_MSG_ERROR([JACK support requires jack (>= 0.102.20)]))
+fi
+AM_CONDITIONAL(WITH_JACK, [test "$build_jack" = "yes"])
build_raptor="yes"
AC_ARG_ENABLE(raptor,
@@ -80,6 +92,15 @@ if test "$build_raptor" = "yes"; then
fi
AM_CONDITIONAL(WITH_RAPTOR, [test "$build_raptor" = "yes"])
+build_rasqal="yes"
+AC_ARG_ENABLE(rasqal,
+ [AS_HELP_STRING(--enable-rasqal, [Include Rasqal (RDF Querying) support (yes)])],
+ [ if test x$enable_rasqal = xno ; then build_rasqal=no ; fi ])
+if test "$build_rasqal" = "yes"; then
+ PKG_CHECK_MODULES(RASQAL, rasqal >= 0.9.11, [],
+ AC_MSG_ERROR([RDF query support requires rasqal (>= 0.9.11)]))
+fi
+AM_CONDITIONAL(WITH_RASQAL, [test "$build_rasqal" = "yes"])
build_liblo="yes"
AC_ARG_ENABLE(liblo,
@@ -107,9 +128,11 @@ AC_MSG_RESULT([Raul build configuration:])
AC_MSG_RESULT([])
AC_MSG_RESULT([Building unit tests: $build_unit_tests])
AC_MSG_RESULT([])
-AC_MSG_RESULT([OSC supprt: $build_liblo])
-AC_MSG_RESULT([RDF supprt: $build_raptor])
-AC_MSG_RESULT([Smart Pointers: $build_smart_pointers])
+AC_MSG_RESULT([OSC (Liblo) support: $build_liblo])
+AC_MSG_RESULT([RDF Serialization (Raptor) support: $build_raptor])
+AC_MSG_RESULT([RDF Querying (Rasqal) support: $build_rasqal])
+AC_MSG_RESULT([Jack support: $build_jack])
+AC_MSG_RESULT([Smart Pointers (Boost): $build_smart_pointers])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([])