summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-01-10 17:41:25 +0000
committerDavid Robillard <d@drobilla.net>2007-01-10 17:41:25 +0000
commite45e85dae29af1a8fef5442aa7c72fa991ac83f1 (patch)
tree04b874fb5202b014352f095f23d031416e394979 /configure.ac
parent4014067a1668d94000b059d72832482a06cf8369 (diff)
downloadraul-e45e85dae29af1a8fef5442aa7c72fa991ac83f1.tar.gz
raul-e45e85dae29af1a8fef5442aa7c72fa991ac83f1.tar.bz2
raul-e45e85dae29af1a8fef5442aa7c72fa991ac83f1.zip
Moved RDFWriter to RAUL.
More work on LADSPA->LV2 converter (use RAUL's RDFWriter now). git-svn-id: http://svn.drobilla.net/lad/raul@246 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b40be9..c0eaf8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,29 @@ AC_CHECK_FUNCS([strdup strerror])
AC_CHECK_HEADER([pthread.h], [],
AC_MSG_ERROR([Raul requires POSIX threads.]))
+# Check for debugging flag
+debug="no"
+AC_ARG_ENABLE(debug,
+ [AS_HELP_STRING(--enable-debug, [Enable debugging (false)])],
+ [debug="$enableval"])
+if test "$debug" = "yes"; then
+ CFLAGS="-O0 -g -DDEBUG"
+ CXXFLAGS="-O0 -g -DDEBUG"
+else
+ CFLAGS="$CFLAGS -DNDEBUG"
+ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+fi
+
+# Check for strict flag
+strict="no"
+AC_ARG_ENABLE(strict,
+ [AS_HELP_STRING(--enable-strict, [Enable strict compiler warnings and errors (false)])],
+ [strict="$enableval"])
+if test "$strict" = "yes"; then
+ CFLAGS="$CFLAGS -std=c99 -pedantic -Wall -Wextra -Wconversion -Winit-self"
+ CXXFLAGS="$CXXFLAGS -ansi -pedantic -Wall -Wextra -Wconversion -Winit-self"
+fi
+
# Build unit tests?
build_unit_tests="no"
AC_ARG_ENABLE(unit-tests,