summaryrefslogtreecommitdiffstats
path: root/raul/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-08-15 19:18:16 +0000
committerDavid Robillard <d@drobilla.net>2008-08-15 19:18:16 +0000
commit6b76fb2295f9745a6f22b7909ac157324be2a6e5 (patch)
tree5ab867b713855a7a40e1312d9a1e277399c084a5 /raul/Makefile.am
parentd372433e02ec32fd62e3f7e1fae00727dd38dd1a (diff)
downloadraul-6b76fb2295f9745a6f22b7909ac157324be2a6e5.tar.gz
raul-6b76fb2295f9745a6f22b7909ac157324be2a6e5.tar.bz2
raul-6b76fb2295f9745a6f22b7909ac157324be2a6e5.zip
Install Raul Symbol.hpp.
Rework aclocal include crap to not use m4 subdirectory, fix ingen building w/ python. Check for SOAP/HTTP support in ingen configure script as well. git-svn-id: http://svn.drobilla.net/lad/raul@1391 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'raul/Makefile.am')
-rw-r--r--raul/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/raul/Makefile.am b/raul/Makefile.am
index 625aa75..fd23b9e 100644
--- a/raul/Makefile.am
+++ b/raul/Makefile.am
@@ -3,10 +3,10 @@ raulincludedir = $(includedir)/raul
raulinclude_HEADERS = \
Array.hpp \
Atom.hpp \
- AtomicInt.hpp \
- AtomicPtr.hpp \
AtomLiblo.hpp \
AtomRDF.hpp \
+ AtomicInt.hpp \
+ AtomicPtr.hpp \
Command.hpp \
Deletable.hpp \
DoubleBuffer.hpp \
@@ -14,30 +14,31 @@ raulinclude_HEADERS = \
JackDriver.hpp \
List.hpp \
ListImpl.hpp \
- lv2_event.h \
- Maid.hpp \
- midi_events.h \
- midi_names.h \
MIDISink.hpp \
+ Maid.hpp \
Path.hpp \
PathTable.hpp \
Process.hpp \
Quantizer.hpp \
RingBuffer.hpp \
- Semaphore.hpp \
- SharedPtr.hpp \
- Slave.hpp \
SMFReader.hpp \
SMFWriter.hpp \
SRMWQueue.hpp \
SRSWQueue.hpp \
+ Semaphore.hpp \
+ SharedPtr.hpp \
+ Slave.hpp \
Stateful.hpp \
+ Symbol.hpp \
Table.hpp \
TableImpl.hpp \
Thread.hpp \
TimeSlice.hpp \
TimeStamp.hpp \
- WeakPtr.hpp
+ WeakPtr.hpp \
+ lv2_event.h \
+ midi_events.h \
+ midi_names.h
if WITH_LASH
raulinclude_HEADERS += LashClient.hpp LashServerInterface.hpp LashProject.hpp