summaryrefslogtreecommitdiffstats
path: root/raul/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-02-09 18:23:57 +0000
committerDavid Robillard <d@drobilla.net>2008-02-09 18:23:57 +0000
commit81f335330c209359ef1d2b3bdedc5c19790d2eba (patch)
tree2262742e60b1360ecd66bf1f5be57e4df2b53de3 /raul/Makefile.am
parent43dd122ffcdb6a0b40a56777245a870e411d439c (diff)
downloadraul-81f335330c209359ef1d2b3bdedc5c19790d2eba.tar.gz
raul-81f335330c209359ef1d2b3bdedc5c19790d2eba.tar.bz2
raul-81f335330c209359ef1d2b3bdedc5c19790d2eba.zip
Use Raul::TimeStamp (LV2 compatible typed 32:32 fixed timestamp) everywhere.
Fix initial size of Patchage messages window. Machina disabled for now (transitioning to generic timestamps). git-svn-id: http://svn.drobilla.net/lad/raul@1133 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'raul/Makefile.am')
-rw-r--r--raul/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/raul/Makefile.am b/raul/Makefile.am
index eeeb792..6c2661b 100644
--- a/raul/Makefile.am
+++ b/raul/Makefile.am
@@ -3,39 +3,40 @@ raulincludedir = $(includedir)/raul
raulinclude_HEADERS = \
Array.hpp \
Atom.hpp \
- AtomLiblo.hpp \
- AtomRDF.hpp \
AtomicInt.hpp \
AtomicPtr.hpp \
+ AtomLiblo.hpp \
+ AtomRDF.hpp \
Command.hpp \
Deletable.hpp \
DoubleBuffer.hpp \
+ EventRingBuffer.hpp \
JackDriver.hpp \
List.hpp \
ListImpl.hpp \
- MIDISink.hpp \
+ lv2_event.h \
Maid.hpp \
+ midi_events.h \
+ MIDISink.hpp \
Path.hpp \
PathTable.hpp \
Process.hpp \
Quantizer.hpp \
RingBuffer.hpp \
+ Semaphore.hpp \
+ SharedPtr.hpp \
+ Slave.hpp \
SMFReader.hpp \
SMFWriter.hpp \
SRMWQueue.hpp \
SRSWQueue.hpp \
- Semaphore.hpp \
- SharedPtr.hpp \
- Slave.hpp \
- StampedChunkRingBuffer.hpp \
Stateful.hpp \
Table.hpp \
TableImpl.hpp \
Thread.hpp \
TimeSlice.hpp \
- WeakPtr.hpp \
- midi_events.h \
- types.hpp
+ TimeStamp.hpp \
+ WeakPtr.hpp
if WITH_LASH
raulinclude_HEADERS += LashClient.hpp LashServerInterface.hpp LashProject.hpp