summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-26 05:52:09 +0000
committerDavid Robillard <d@drobilla.net>2007-07-26 05:52:09 +0000
commit71844dd2056e72bc1b82570e4754cbeeac4de344 (patch)
treefbfa99b80a0dcaab8bc32dacfdd526d0efcfef49 /tests/Makefile.am
parentae1ae583cebc1230afc4db3939a8d47579266653 (diff)
downloadraul-71844dd2056e72bc1b82570e4754cbeeac4de344.tar.gz
raul-71844dd2056e72bc1b82570e4754cbeeac4de344.tar.bz2
raul-71844dd2056e72bc1b82570e4754cbeeac4de344.zip
Added Raul::Table class (like an std::map but in an array, very fast to do a sorted iteration).
Fixed unit test building. git-svn-id: http://svn.drobilla.net/lad/raul@629 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 27a8f1a..ae3db13 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,8 @@ noinst_PROGRAMS = \
time_test \
quantize_test \
smf_test \
- rdf_test
+ rdf_test \
+ table_test
thread_test_LDADD = $(ALL_LIBS)
path_test_LDADD = $(ALL_LIBS)
@@ -27,6 +28,7 @@ time_test_LDADD = $(ALL_LIBS)
quantize_test_LDADD = $(ALL_LIBS)
smf_test_LDADD = $(ALL_LIBS)
rdf_test_LDADD = $(ALL_LIBS)
+table_test_LDADD = $(ALL_LIBS)
path_test_SOURCES = path_test.cpp
thread_test_SOURCES = thread_test.cpp
@@ -39,5 +41,6 @@ time_test_SOURCES = time_test.cpp
quantize_test_SOURCES = quantize_test.cpp
smf_test_SOURCES = smf_test.cpp
rdf_test_SOURCES = rdf_test.cpp
+table_test_SOURCES = table_test.cpp
endif