summaryrefslogtreecommitdiffstats
path: root/raul/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'raul/Makefile.am')
-rw-r--r--raul/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/raul/Makefile.am b/raul/Makefile.am
new file mode 100644
index 0000000..7d5ac48
--- /dev/null
+++ b/raul/Makefile.am
@@ -0,0 +1,21 @@
+raulincludedir = $(includedir)/raul
+
+raulinclude_HEADERS = \
+ SharedPtr.h \
+ WeakPtr.h \
+ Path.h \
+ Queue.h \
+ Semaphore.h \
+ Mutex.h \
+ Condition.h \
+ Thread.h \
+ Slave.h \
+ Atom.h
+
+if WITH_LIBLO
+raulinclude_HEADERS += AtomLiblo.h
+endif
+
+if WITH_RAPTOR
+raulinclude_HEADERS += AtomRaptor.h
+endif