summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0732d07..2389628 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,12 @@
if BUILD_TESTS
-AM_CXXFLAGS = -I..
-bin_PROGRAMS = path_test
+AM_CXXFLAGS = -I.. -lpthread
+bin_PROGRAMS = path_test thread_test queue_test
+
+thread_test_LDADD = ../src/libraul.la
path_test_SOURCES = path_test.cpp
+thread_test_SOURCES = thread_test.cpp
+queue_test_SOURCES = queue_test.cpp
endif