aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-08-13 20:31:57 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commit0e739f34801ff6810064a8fac570f6be2b61ae70 (patch)
tree4451739f8e9b00d490d2d59aa6b1f370ae99c356 /meson.build
parent63e7e57237a79d0447b0450a7fd3148c43052299 (diff)
downloadserd-0e739f34801ff6810064a8fac570f6be2b61ae70.tar.gz
serd-0e739f34801ff6810064a8fac570f6be2b61ae70.tar.bz2
serd-0e739f34801ff6810064a8fac570f6be2b61ae70.zip
Simplify output stream API
This makes the paging mechanism an internal detail once again. While it's conceptually elegant to simply have a single write interface and have the block dumper just be another implementation of that, unfortunately it is not practical. The inlining of serd_block_dumper_write() is a significant performance boost, because it avoids a non-inlinable function call of overhead per character. Compared to the SerdByteSink approach, this removes the burden and overhead of needing to dynamically allocate the structure itself.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c1713ce6..eebe55be 100644
--- a/meson.build
+++ b/meson.build
@@ -86,8 +86,8 @@ c_header_files = files(c_headers)
c_header = files('include/serd/serd.h')
sources = [
+ 'src/block_dumper.c',
'src/buffer.c',
- 'src/byte_sink.c',
'src/byte_source.c',
'src/canon.c',
'src/caret.c',
@@ -103,6 +103,7 @@ sources = [
'src/node.c',
'src/node_syntax.c',
'src/nodes.c',
+ 'src/output_stream.c',
'src/read_nquads.c',
'src/read_ntriples.c',
'src/read_utf8.c',