aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-15 20:52:51 -0400
committerDavid Robillard <d@drobilla.net>2023-05-15 20:52:51 -0400
commitdbf48d099a78d2075e224549a28e690d56a6d503 (patch)
treeff34729fbe3dff22374fce22acf8a5430ef86fd8 /meson.build
parentf9ad303b2e7028dffb41a29f2c39278dd13b1bc8 (diff)
downloadserd-dbf48d099a78d2075e224549a28e690d56a6d503.tar.gz
serd-dbf48d099a78d2075e224549a28e690d56a6d503.tar.bz2
serd-dbf48d099a78d2075e224549a28e690d56a6d503.zip
Clean up and organize configuration summary
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build46
1 files changed, 31 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index 0c9c2847..44fc3328 100644
--- a/meson.build
+++ b/meson.build
@@ -190,6 +190,37 @@ if not get_option('tools').disabled()
endif
endif
+# Display top-level summary (before subdirectories to appear first)
+if not meson.is_subproject()
+ summary(
+ {
+ 'Tests': not get_option('tests').disabled(),
+ 'Tools': not get_option('tools').disabled(),
+ },
+ bool_yn: true,
+ section: 'Components',
+ )
+
+ summary(
+ {
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'Libraries': get_option('prefix') / get_option('libdir'),
+ },
+ section: 'Directories',
+ )
+
+ if not get_option('tools').disabled()
+ summary(
+ {
+ 'Executables': get_option('prefix') / get_option('bindir'),
+ 'Man pages': get_option('prefix') / get_option('mandir'),
+ },
+ section: 'Directories',
+ )
+ endif
+endif
+
###########
# Support #
###########
@@ -217,18 +248,3 @@ endif
if not get_option('docs').disabled()
subdir('doc')
endif
-
-if not meson.is_subproject()
- summary('Tests', not get_option('tests').disabled(), bool_yn: true)
- summary('Tools', not get_option('tools').disabled(), bool_yn: true)
-
- summary('Install prefix', get_option('prefix'))
-
- summary('Headers', get_option('prefix') / get_option('includedir'))
- summary('Libraries', get_option('prefix') / get_option('libdir'))
-
- if not get_option('tools').disabled()
- summary('Executables', get_option('prefix') / get_option('bindir'))
- summary('Man pages', get_option('prefix') / get_option('mandir'))
- endif
-endif