aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2018-05-27 15:48:25 +0200
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:29 -0500
commitf93a441065a611cc32874dde67e53a8295c87baf (patch)
tree3793e2df1c365bf93fbe700c9428b54668f08c53 /meson.build
parent2c5bee49b4494e172c4fa147af91bad199ed9362 (diff)
downloadserd-f93a441065a611cc32874dde67e53a8295c87baf.tar.gz
serd-f93a441065a611cc32874dde67e53a8295c87baf.tar.bz2
serd-f93a441065a611cc32874dde67e53a8295c87baf.zip
[WIP] Add validation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 326e5fbf..0620db02 100644
--- a/meson.build
+++ b/meson.build
@@ -58,6 +58,7 @@ if get_option('strict')
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
'/wd4774', # format string is not a string literal
+ '/wd4777', # format string '%lld' requires a '__int64_ argument
'/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
'/wd4996', # POSIX name for this item is deprecated
@@ -118,6 +119,7 @@ sources = [
'src/syntax.c',
'src/system.c',
'src/uri.c',
+ 'src/validate.c',
'src/value.c',
'src/world.c',
'src/writer.c',
@@ -179,6 +181,10 @@ exess_dep = dependency('exess-0',
version: '>= 0.0.1',
fallback: ['exess', 'exess_dep'])
+rerex_dep = dependency('rerex-0',
+ version: '>= 0.0.1',
+ fallback: ['rerex', 'rerex_dep'])
+
# Build shared and/or static library/libraries
libserd = build_target(
library_name,
@@ -186,7 +192,7 @@ libserd = build_target(
version: meson.project_version(),
include_directories: include_directories('include', 'src'),
c_args: c_warnings + platform_args + library_args,
- dependencies: [exess_dep, m_dep, zix_dep],
+ dependencies: [exess_dep, m_dep, rerex_dep, zix_dep],
gnu_symbol_visibility: 'hidden',
install: true,
target_type: library_type)
@@ -225,6 +231,8 @@ if get_option('tests')
subdir('test')
endif
+subdir('schemas')
+
if not meson.is_subproject() and meson.version().version_compare('>=0.53.0')
summary('Tests', get_option('tests'), bool_yn: true)
summary('Tools', get_option('tools'), bool_yn: true)