aboutsummaryrefslogtreecommitdiffstats
path: root/subprojects/exess/doc/c/man/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-02-25 10:27:59 -0500
committerDavid Robillard <d@drobilla.net>2021-03-08 23:23:05 -0500
commitc4821c8e6bf1f81c6ea31e11ebc0fc1666e9337b (patch)
treea62995534f5f606ac2f8bae22d525532b824cb5e /subprojects/exess/doc/c/man/meson.build
parent6bcd18ae60482790b645a345f718e7099250f261 (diff)
downloadserd-c4821c8e6bf1f81c6ea31e11ebc0fc1666e9337b.tar.gz
serd-c4821c8e6bf1f81c6ea31e11ebc0fc1666e9337b.tar.bz2
serd-c4821c8e6bf1f81c6ea31e11ebc0fc1666e9337b.zip
Add exess from git@gitlab.com:drobilla/exess.git 4638b1f
Diffstat (limited to 'subprojects/exess/doc/c/man/meson.build')
-rw-r--r--subprojects/exess/doc/c/man/meson.build122
1 files changed, 122 insertions, 0 deletions
diff --git a/subprojects/exess/doc/c/man/meson.build b/subprojects/exess/doc/c/man/meson.build
new file mode 100644
index 00000000..d2a31557
--- /dev/null
+++ b/subprojects/exess/doc/c/man/meson.build
@@ -0,0 +1,122 @@
+# Run Sphinx to generate group man pages
+
+# Group man pages generated by Sphinx
+man_pages = [
+ 'exess_base64.3',
+ 'exess_binary.3',
+ 'exess_boolean.3',
+ 'exess_coercion.3',
+ 'exess_byte.3',
+ 'exess_datatypes.3',
+ 'exess_date.3',
+ 'exess_datetime.3',
+ 'exess_decimal.3',
+ 'exess_double.3',
+ 'exess_duration.3',
+ 'exess_float.3',
+ 'exess_hex.3',
+ 'exess_int.3',
+ 'exess_long.3',
+ # 'exess_numbers.3',
+ 'exess_short.3',
+ 'exess_status.3',
+ 'exess_time.3',
+ 'exess_timezone.3',
+ 'exess_ubyte.3',
+ 'exess_uint.3',
+ 'exess_ulong.3',
+ 'exess_ushort.3',
+ 'exess_variant.3',
+]
+
+# Run Sphinx to generate man pages
+man_docs = custom_target(
+ 'man pages for exess',
+ command: [sphinx_build, '-M', 'man',
+ meson.current_build_dir() / '..', meson.current_build_dir() / '..',
+ '-E', '-q', '-t', 'man'],
+ input: [c_rst_files, c_exess_rst, c_index_xml],
+ output: man_pages,
+ build_by_default: true,
+ install: true,
+ install_dir: get_option('mandir') / 'man3')
+
+
+
+# message(man_docs.extract_all_objects())
+
+# foreach man_page : man_pages
+# install_man(man_docs[0])#meson.current_build_dir() / man_page)
+# endforeach
+
+# "Links" from symbol names to corresponding page (one-line includes)
+man_links = [
+ ['ExessStatus.3', 'exess_status.3'],
+ ['ExessResult.3', 'exess_status.3'],
+ ['exess_strerror.3', 'exess_status.3'],
+ ['exess_read_decimal.3', 'exess_decimal.3'],
+ ['exess_write_decimal.3', 'exess_decimal.3'],
+ ['exess_read_double.3', 'exess_double.3'],
+ ['exess_write_double.3', 'exess_double.3'],
+ ['exess_read_float.3', 'exess_float.3'],
+ ['exess_write_float.3', 'exess_float.3'],
+ ['exess_read_boolean.3', 'exess_boolean.3'],
+ ['exess_write_boolean.3', 'exess_boolean.3'],
+ ['exess_read_long.3', 'exess_long.3'],
+ ['exess_write_long.3', 'exess_long.3'],
+ ['exess_read_int.3', 'exess_int.3'],
+ ['exess_write_int.3', 'exess_int.3'],
+ ['exess_read_short.3', 'exess_short.3'],
+ ['exess_write_short.3', 'exess_short.3'],
+ ['exess_read_byte.3', 'exess_byte.3'],
+ ['exess_write_byte.3', 'exess_byte.3'],
+ ['exess_read_ulong.3', 'exess_ulong.3'],
+ ['exess_write_ulong.3', 'exess_ulong.3'],
+ ['exess_read_uint.3', 'exess_uint.3'],
+ ['exess_write_uint.3', 'exess_uint.3'],
+ ['exess_read_ushort.3', 'exess_ushort.3'],
+ ['exess_write_ushort.3', 'exess_ushort.3'],
+ ['exess_read_ubyte.3', 'exess_ubyte.3'],
+ ['exess_write_ubyte.3', 'exess_ubyte.3'],
+ ['ExessDuration.3', 'exess_duration.3'],
+ ['exess_read_duration.3', 'exess_duration.3'],
+ ['exess_write_duration.3', 'exess_duration.3'],
+ ['ExessDateTime.3', 'exess_datetime.3'],
+ ['exess_read_datetime.3', 'exess_datetime.3'],
+ ['exess_write_datetime.3', 'exess_datetime.3'],
+ ['ExessTimezone.3', 'exess_timezone.3'],
+ ['ExessDate.3', 'exess_date.3'],
+ ['exess_read_date.3', 'exess_date.3'],
+ ['exess_write_date.3', 'exess_date.3'],
+ ['ExessTime.3', 'exess_time.3'],
+ ['exess_read_time.3', 'exess_time.3'],
+ ['exess_write_time.3', 'exess_time.3'],
+ ['ExessBlob.3', 'exess_binary.3'],
+ ['ExessDatatype.3', 'exess_datatypes.3'],
+ ['ExessValue.3', 'exess_variant.3'],
+ ['ExessVariant.3', 'exess_variant.3'],
+ ['exess_read_variant.3', 'exess_variant.3'],
+ ['exess_write_variant.3', 'exess_variant.3'],
+ ['exess_write_canonical.3', 'exess_variant.3'],
+ ['ExessCoercionFlag.3', 'exess_variant.3'],
+ ['ExessCoercionFlags.3', 'exess_variant.3'],
+ ['exess_coerce.3', 'exess_variant.3'],
+]
+
+foreach man_link : man_links
+ link = man_link[0]
+ target = man_link[1]
+
+ config = configuration_data()
+ config.set('TARGET', target)
+
+ manlink = configure_file(configuration: config,
+ input: 'manlink.in',
+ output: link,
+ install: true,
+ install_dir: get_option('mandir') / 'man3')
+
+ # message(target)
+
+ # install_man(manlink)
+endforeach