aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-11-25 07:05:28 -0500
committerDavid Robillard <d@drobilla.net>2022-11-25 07:33:22 -0500
commit445a56f6d576f1d5bd3f61fd5e722722b563ee74 (patch)
tree6a49cef136f904a865c0c0dd7b35048ef8234288 /test/headers/meson.build
parentae5a48ad57b56d2fefe167b4eb1a5f3c4111c2e0 (diff)
downloadserd-445a56f6d576f1d5bd3f61fd5e722722b563ee74.tar.gz
serd-445a56f6d576f1d5bd3f61fd5e722722b563ee74.tar.bz2
serd-445a56f6d576f1d5bd3f61fd5e722722b563ee74.zip
Trim redundant warning flags enabled by -Wextra and -Wpedantic
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index af270073..0c4e97ea 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -6,7 +6,6 @@ header_c_suppressions = []
if get_option('strict')
if cc.get_id() == 'clang'
header_c_suppressions += [
- '-Wno-nullability-extension',
'-Wno-padded',
]
elif cc.get_id() == 'gcc'
@@ -21,6 +20,12 @@ if get_option('strict')
endif
endif
+if cc.get_id() == 'clang'
+ header_c_suppressions += [
+ '-Wno-nullability-extension',
+ ]
+endif
+
test(
'headers',
executable(