aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2020-06-28 23:26:48 +0200
committerDavid Robillard <d@drobilla.net>2022-01-13 23:05:24 -0500
commit55e28966226268a57edb07419ac419ef53ac437d (patch)
tree317a3e50480f97a415dae5a7d096726a0c730c0a /test/meson.build
parentb98bd7a32cf4302e0a210dd8558edd3ab2088525 (diff)
downloadserd-55e28966226268a57edb07419ac419ef53ac437d.tar.gz
serd-55e28966226268a57edb07419ac419ef53ac437d.tar.bz2
serd-55e28966226268a57edb07419ac419ef53ac437d.zip
Make Reader always read from a ByteSource
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build16
1 files changed, 12 insertions, 4 deletions
diff --git a/test/meson.build b/test/meson.build
index b6c2ce2f..5063277b 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -6,6 +6,7 @@ wrapper = meson.get_cross_property('exe_wrapper', '')
unit_tests = [
'byte_sink',
+ 'byte_source',
'caret',
'env',
'free_null',
@@ -160,25 +161,32 @@ if get_option('utils')
# IO errors
test('read_dir', serdi,
- args: ['-e', 'file://@0@/'.format(meson.source_root())],
+ args: ['-e', meson.source_root()],
env: test_env,
should_fail: true,
suite: 'io_errors')
test('bulk_read_dir', serdi,
- args: ['file://@0@/'.format(meson.source_root())],
+ args: [meson.source_root()],
env: test_env,
should_fail: true,
suite: 'io_errors')
+ if host_machine.system() == 'linux'
+ test('unreadable', serdi,
+ args: ['/sys/bus/pci/rescan'],
+ env: test_env,
+ should_fail: true,
+ suite: 'io_errors')
+ endif
+
test('write_error', files('test_write_error.py'),
args: script_args + [serd_ttl],
env: test_env,
suite: 'io_errors')
test('write_bad_file', serdi,
- args: ['-w', '/does/not/exist.ttl',
- 'file://@0@/serd.ttl'.format(meson.source_root())],
+ args: ['-w', '/does/not/exist.ttl', meson.source_root() / 'serd.ttl'],
env: test_env,
should_fail: true,
suite: 'io_errors')