aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-08-08 14:24:59 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commit5aa146e1ce58d295b5f45446bbbbdbb30c8e557d (patch)
treec8b49564b251bf2c3ff63bbfdc932986bea8d0b6 /test/meson.build
parentbaa2e4e768f542953144cfa6ebe5713ecad389fc (diff)
downloadserd-5aa146e1ce58d295b5f45446bbbbdbb30c8e557d.tar.gz
serd-5aa146e1ce58d295b5f45446bbbbdbb30c8e557d.tar.bz2
serd-5aa146e1ce58d295b5f45446bbbbdbb30c8e557d.zip
Replace serdi -b and -e options with a block size option
This is more powerful, and reduces the number of command line options that almost nobody needs to care about.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build10
1 files changed, 4 insertions, 6 deletions
diff --git a/test/meson.build b/test/meson.build
index 67907c25..898062f0 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -86,6 +86,10 @@ if get_option('utils')
['-G', '?s ?p ?o . ?q ?r ?s .', '-s', ''],
['-G', 'bad_pattern', '-s', ''],
['-I'],
+ ['-b'],
+ ['-b', '-1'],
+ ['-b', '9223372036854775807'],
+ ['-b', '1024junk'],
['-c'],
['-i', 'unknown'],
['-i', 'turtle'],
@@ -201,12 +205,6 @@ if get_option('utils')
# IO errors
test('read_dir', serdi,
- args: ['-e', meson.source_root()],
- env: test_env,
- should_fail: true,
- suite: 'io_errors')
-
- test('bulk_read_dir', serdi,
args: [meson.source_root()],
env: test_env,
should_fail: true,