aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-04-03 09:00:00 -0400
committerDavid Robillard <d@drobilla.net>2023-04-05 09:45:15 -0400
commitaa2a43dac355ff77a7cedd03cd8c55f5f3e98936 (patch)
tree953fa74dc1b00fbb137ab5026f287aa6a002e118 /test/meson.build
parent37750163c9aaef29a3ff2ad57fe49e5db99359cc (diff)
downloadserd-aa2a43dac355ff77a7cedd03cd8c55f5f3e98936.tar.gz
serd-aa2a43dac355ff77a7cedd03cd8c55f5f3e98936.tar.bz2
serd-aa2a43dac355ff77a7cedd03cd8c55f5f3e98936.zip
Run lax suite with the simpler runner script
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build26
1 files changed, 8 insertions, 18 deletions
diff --git a/test/meson.build b/test/meson.build
index e4850f0c..f5282672 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -195,6 +195,14 @@ ns_serdtest = 'http://drobilla.net/sw/serd/test/'
ns_w3 = 'http://www.w3.org/2013/'
test_suites = {
+ 'lax.lax': [
+ '--lax',
+ files('lax/manifest.ttl'), ns_serdtest + 'lax/',
+ '--', '-l',
+ ],
+ 'lax.strict': [
+ files('lax/manifest.ttl'), ns_serdtest + 'lax/',
+ ],
'prefix.add': [
'--reverse',
files('prefix/manifest.ttl'), ns_serdtest + 'prefix/',
@@ -253,24 +261,6 @@ if not get_option('tools').disabled()
suite: ['rdf', 'serd'],
timeout: 240)
- ### The lax suite is special because it is run twice...
- lax_manifest = files('lax/manifest.ttl')
- lax_base_uri = ns_serdtest + 'lax/'
-
- ### ... once with strict parsing to test the hard errors
- test('lax.strict', run_test_suite,
- args: script_args + [lax_manifest, lax_base_uri],
- is_parallel: false,
- suite: ['rdf', 'serd'],
- timeout: 240)
-
- ### ... and once with lax parsing to tolerate them
- test('lax.lax', run_test_suite,
- args: script_args + [lax_manifest, lax_base_uri, '--', '-l'],
- is_parallel: false,
- suite: ['rdf', 'serd'],
- timeout: 240)
-
## Standard W3C test suites
w3c_suites = ['Turtle', 'NTriples', 'NQuads', 'TriG']