aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2020-06-28 19:46:47 +0200
committerDavid Robillard <d@drobilla.net>2022-01-13 23:04:17 -0500
commitcae15d15c847faba203e40e2a327b23a1ebffb48 (patch)
tree17d1e637673ef45c3afdc3c43b67f0b023b8d851 /test/meson.build
parent900d360027d570da085d495becde1ad50f050048 (diff)
downloadserd-cae15d15c847faba203e40e2a327b23a1ebffb48.tar.gz
serd-cae15d15c847faba203e40e2a327b23a1ebffb48.tar.bz2
serd-cae15d15c847faba203e40e2a327b23a1ebffb48.zip
Make Writer always write to a ByteSink
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 9724f18e..1245e29d 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -5,6 +5,7 @@ run_test_suite = find_program('run_test_suite.py')
wrapper = meson.get_cross_property('exe_wrapper', '')
unit_tests = [
+ 'byte_sink',
'caret',
'env',
'free_null',
@@ -83,6 +84,7 @@ if get_option('utils')
['-o'],
['-p'],
['-r'],
+ ['-w'],
['-z'],
['-s', '<foo> a <Bar> .'],
]
@@ -166,6 +168,13 @@ if get_option('utils')
env: test_env,
suite: 'io_errors')
+ test('write_bad_file', serdi,
+ args: ['-w', '/does/not/exist.ttl',
+ 'file://@0@/serd.ttl'.format(meson.source_root())],
+ env: test_env,
+ should_fail: true,
+ suite: 'io_errors')
+
# RDF test suites
## Serd-specific test suites