aboutsummaryrefslogtreecommitdiffstats
path: root/test/pretty/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-08-12 22:28:59 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commit1409f161793a289819df1f31eccb579b71f45475 (patch)
tree4076c291a397f0a0a2ea560305ee87c47810df33 /test/pretty/meson.build
parent6ffe331cfc8af0735b263ab7af6f84b1b4418102 (diff)
downloadserd-1409f161793a289819df1f31eccb579b71f45475.tar.gz
serd-1409f161793a289819df1f31eccb579b71f45475.tar.bz2
serd-1409f161793a289819df1f31eccb579b71f45475.zip
Fix pretty-printing nested empty lists and add test suite
The earlier "test" was just hitting the code without actually checking the output. This new suite is a set of pretty-printed documents which serd must reproduce from a model exactly to pass. This should make it easy to add cases in the future, since each case is just a document, as it should look.
Diffstat (limited to 'test/pretty/meson.build')
-rw-r--r--test/pretty/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/pretty/meson.build b/test/pretty/meson.build
new file mode 100644
index 00000000..634f1e0e
--- /dev/null
+++ b/test/pretty/meson.build
@@ -0,0 +1,17 @@
+base_uri = 'http://drobilla.net/sw/serd/test/good/'
+
+args = [files('manifest.ttl')]
+
+test('pretty',
+ run_pretty_suite,
+ args: pipe_test_script_args + ['-o', meson.current_build_dir() / 'pipe'] + args,
+ env: test_env,
+ suite: ['suite', 'extra', 'pipe'],
+ timeout: 240)
+
+test('pretty',
+ run_pretty_suite,
+ args: sort_test_script_args + ['-o', meson.current_build_dir() / 'sort'] + args,
+ env: test_env,
+ suite: ['suite', 'extra', 'sort'],
+ timeout: 240)