aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-08-08 14:30:42 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commit62a515492994a0320b1c45e87b4360adbf1ae9ba (patch)
tree4a12b44ded17f5a3d97e447449379c19dc1da53b /tools/meson.build
parent5aa146e1ce58d295b5f45446bbbbdbb30c8e557d (diff)
downloadserd-62a515492994a0320b1c45e87b4360adbf1ae9ba.tar.gz
serd-62a515492994a0320b1c45e87b4360adbf1ae9ba.tar.bz2
serd-62a515492994a0320b1c45e87b4360adbf1ae9ba.zip
Move serdi to tools subdirectory
This separates the command-line tool code from the library implementation.
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 00000000..3054364a
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,13 @@
+tool_c_args = c_warnings + platform_args + prog_args
+tool_link_args = []
+
+if get_option('static')
+ tool_link_args += ['-static']
+endif
+
+serdi = executable('serdi',
+ ['serdi.c', 'console.c'],
+ c_args: tool_c_args,
+ link_args: tool_link_args,
+ install: true,
+ dependencies: serd_dep)