aboutsummaryrefslogtreecommitdiffstats
path: root/doc/html/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/html/meson.build')
-rw-r--r--doc/html/meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/doc/html/meson.build b/doc/html/meson.build
index a6f1d6fe..d97d368b 100644
--- a/doc/html/meson.build
+++ b/doc/html/meson.build
@@ -8,10 +8,12 @@ html_dir = docdir / versioned_name / 'html'
custom_target(
'html',
build_by_default: true,
- command: [
- sphinx_build, '-M', 'html', '@OUTDIR@' / '..', '@OUTDIR@' / '..',
+ command: sphinx_build_command + [
+ '-b', 'html',
'-t', 'html',
- ] + sphinx_flags,
+ sphinx_in_dir,
+ '@OUTDIR@',
+ ],
input: [c_rst_files, c_serd_rst, c_index_xml, conf_py],
install: true,
install_dir: html_dir,
@@ -25,5 +27,5 @@ custom_target(
)
if not meson.is_subproject()
- summary('Paginated HTML', get_option('prefix') / html_dir, section: 'Directories')
+ summary('HTML', get_option('prefix') / html_dir, section: 'Directories')
endif