aboutsummaryrefslogtreecommitdiffstats
path: root/doc/singlehtml/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/singlehtml/meson.build')
-rw-r--r--doc/singlehtml/meson.build14
1 files changed, 10 insertions, 4 deletions
diff --git a/doc/singlehtml/meson.build b/doc/singlehtml/meson.build
index a15a69ec..47ecb9f8 100644
--- a/doc/singlehtml/meson.build
+++ b/doc/singlehtml/meson.build
@@ -8,10 +8,12 @@ singlehtml_dir = docdir / versioned_name / 'singlehtml'
custom_target(
'singlehtml',
build_by_default: true,
- command: [
- sphinx_build, '-M', 'singlehtml', '@OUTDIR@' / '..', '@OUTDIR@' / '..',
+ command: sphinx_build_command + [
+ '-b', 'singlehtml',
'-t', 'singlehtml',
- ] + sphinx_flags,
+ sphinx_in_dir,
+ '@OUTDIR@',
+ ],
input: [c_rst_files, c_serd_rst, c_index_xml, conf_py],
install: true,
install_dir: singlehtml_dir,
@@ -22,5 +24,9 @@ custom_target(
)
if not meson.is_subproject()
- summary('Unified HTML', get_option('prefix') / singlehtml_dir, section: 'Directories')
+ summary(
+ 'Single HTML',
+ get_option('prefix') / singlehtml_dir,
+ section: 'Directories',
+ )
endif