aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 0f457809..afcc39f1 100644
--- a/meson.build
+++ b/meson.build
@@ -52,7 +52,7 @@ if get_option('strict')
elif cc.get_id() == 'msvc'
c_suppressions += [
'/wd4061', # enumerator in switch is not explicitly handled
- '/wd4365', # signed/unsigned mismatch
+ '/wd4200', # nonstandard: zero-sized array in struct/union
'/wd4514', # unreferenced inline function has been removed
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
@@ -121,7 +121,7 @@ if get_option('default_library') == 'both'
prog_args = []
library_type = 'both_libraries'
- library_args = ['-DSERD_INTERNAL']
+ library_args = ['-DSERD_INTERNAL', '-DZIX_API=']
elif get_option('default_library') == 'shared'
if host_machine.system() == 'windows'
# Meson annoyingly adds its own suffix, so remove this one
@@ -130,7 +130,7 @@ elif get_option('default_library') == 'shared'
prog_args = []
library_type = 'shared_library'
- library_args = ['-DSERD_INTERNAL']
+ library_args = ['-DSERD_INTERNAL', '-DZIX_API=']
else
prog_args = ['-DSERD_STATIC']
library_type = 'static_library'
@@ -138,6 +138,7 @@ else
'-DEXESS_STATIC',
'-DSERD_INTERNAL',
'-DSERD_STATIC',
+ '-DZIX_API=',
]
endif