aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 35aeb2ad..81415fe5 100644
--- a/meson.build
+++ b/meson.build
@@ -19,6 +19,10 @@ versioned_name = 'serd' + version_suffix
pkg = import('pkgconfig')
cc = meson.get_compiler('c')
+if add_languages('cpp', required: get_option('bindings_cpp'))
+ cpp = meson.get_compiler('cpp')
+endif
+
# Set ultra strict warnings for developers, if requested
if get_option('strict')
subdir('meson')
@@ -194,6 +198,11 @@ if get_option('tests')
subdir('test')
endif
+# C++ bindings
+if is_variable('cpp')
+ subdir('bindings/cpp')
+endif
+
if meson.version().version_compare('>=0.53.0')
summary('Tests', get_option('tests'), bool_yn: true)
summary('Utilities', get_option('utils'), bool_yn: true)