aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
new file mode 100644
index 00000000..ac9dc2d2
--- /dev/null
+++ b/test/headers/meson.build
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+header_c_suppressions = []
+
+if get_option('strict')
+ if cc.get_id() == 'clang'
+ header_c_suppressions += [
+ '-Wno-nullability-extension',
+ '-Wno-padded',
+ ]
+ elif cc.get_id() == 'gcc'
+ header_c_suppressions += [
+ '-Wno-padded',
+ '-Wno-unused-const-variable',
+ ]
+ endif
+endif
+
+test(
+ 'headers',
+ executable(
+ 'test_headers',
+ files('test_headers.c'),
+ c_args: header_c_suppressions,
+ dependencies: serd_dep,
+ ),
+ suite: 'unit',
+)