aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index 78a48618..6cb14f6e 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -8,6 +8,11 @@ if get_option('warning_level') == 'everything'
header_c_suppressions += [
'-Wno-padded',
]
+
+ if not meson.is_cross_build()
+ header_c_suppressions += ['-Wno-poison-system-directories']
+ endif
+
elif cc.get_id() == 'gcc'
header_c_suppressions += [
'-Wno-padded',