aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 222ec1bc..4d9d2b43 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -10,6 +10,7 @@ unit_tests = [
'caret',
'env',
'free_null',
+ 'log',
'node',
'nodes',
'overflow',
@@ -102,6 +103,24 @@ if get_option('utils')
suite: ['serdi', 'options'])
endforeach
+ test('ansi_clicolor_force',
+ serdi,
+ args: files('bad/bad-lang.ttl'),
+ env: test_env + ['CLICOLOR_FORCE=1'],
+ should_fail: true)
+
+ test('ansi_clicolor_off',
+ serdi,
+ args: files('bad/bad-lang.ttl'),
+ env: test_env + ['CLICOLOR=0'],
+ should_fail: true)
+
+ test('ansi_no_color',
+ serdi,
+ args: files('bad/bad-lang.ttl'),
+ env: test_env + ['NO_COLOR=1'],
+ should_fail: true)
+
test('none',
serdi,
env: test_env,