aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build26
1 files changed, 14 insertions, 12 deletions
diff --git a/test/meson.build b/test/meson.build
index 57576f04..1aaa7183 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -9,20 +9,22 @@ wrapper = meson.get_external_property('exe_wrapper', '')
# Project Metadata #
####################
-# Check release metadata
-if get_option('strict') and not meson.is_subproject()
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test('autoship', autoship, args: ['test', serd_src_root], suite: 'data')
+if get_option('strict')
+ # Check release metadata
+ if not meson.is_subproject()
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship, args: ['test', serd_src_root], suite: 'data')
+ endif
endif
-endif
-# Check licensing metadata
-reuse = find_program('reuse', required: false)
-if reuse.found()
- test('REUSE', reuse,
- args: ['--root', serd_src_root, 'lint'],
- suite: 'data')
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ test('REUSE', reuse,
+ args: ['--root', serd_src_root, 'lint'],
+ suite: 'data')
+ endif
endif
##############