aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/test/meson.build b/test/meson.build
index 9830a1dd..c0ed56e4 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -81,9 +81,7 @@ if is_variable('serd_pipe')
# Basic invalid arguments
bad_args = [
- ['-B', 'nonuriorpath'],
['-B'],
- ['-I', 'turtle'],
['-I', 'unknown'],
['-I'],
['-O', 'unknown'],
@@ -112,12 +110,6 @@ if is_variable('serd_pipe')
suite: ['tools', 'pipe', 'options'])
endforeach
- test('none',
- tool,
- env: test_env,
- should_fail: true,
- suite: ['tools', 'pipe', 'options'])
-
test('remote',
tool,
args: ['ftp://unsupported.org'],
@@ -287,12 +279,6 @@ if is_variable('serd_sort')
suite: ['tools', 'sort', 'options'])
endforeach
- test('none',
- tool,
- env: test_env,
- should_fail: true,
- suite: ['tools', 'sort', 'options'])
-
# IO errors
test('read_dir',
@@ -343,7 +329,6 @@ if is_variable('serd_filter')
bad_args = [
['-f', '/no/such/file.nt', '-'],
['-z'],
- ['?s ?p ?o .'],
]
foreach args : bad_args
@@ -381,13 +366,6 @@ if is_variable('serd_filter')
# Different input sources
- test('missing_input',
- tool,
- args: ['?s ?p ?o .', '/does/not/exist.ttl'],
- env: test_env,
- should_fail: true,
- suite: ['tools', 'filter', 'input'])
-
test('filter_dir',
tool,
args: ['?s ?p ?o .', meson.source_root()],