aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index c4dc4b3b..e8392559 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -249,6 +249,14 @@ if get_option('utils')
suite: ['rdf', 'serd'],
timeout: 240)
+ manifest = files('canon' / 'manifest.ttl')
+ base_uri = serd_base + 'canon' + '/'
+ test('canon', run_test_suite,
+ args: script_args + [manifest, base_uri, '--', '-C'],
+ env: test_env,
+ suite: ['rdf', 'serd'],
+ timeout: 240)
+
### The lax suite is special because it is run twice...
lax_manifest = files('lax/manifest.ttl')
lax_base_uri = serd_base + name + '/'