aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 8a76bbb6..cd748c0c 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -16,6 +16,7 @@ unit_tests = [
'sink',
'statement',
'string',
+ 'terse_write',
'uri',
'world',
'writer',
@@ -163,7 +164,7 @@ if get_option('utils')
serd_suites = ['good', 'bad']
serd_base = 'http://drobilla.net/sw/serd/test/'
- ### Run all suites with no special arguments
+ ### Run basic suites with no special arguments
foreach name : serd_suites
manifest = files(name / 'manifest.ttl')
base_uri = serd_base + name + '/'
@@ -174,6 +175,16 @@ if get_option('utils')
timeout: 240)
endforeach
+ ### The terse suite needs to be run with -t
+ test('terse', run_test_suite,
+ args: script_args + ['--osyntax', 'turtle',
+ files('terse/manifest.ttl'),
+ serd_base + 'terse/',
+ '--', '-t'],
+ env: test_env,
+ suite: ['rdf', 'serd'],
+ timeout: 240)
+
### The lax suite is special because it is run twice...
lax_manifest = files('lax/manifest.ttl')
lax_base_uri = serd_base + name + '/'