aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/meson.build b/test/meson.build
index 2cf3f32c..95fa9587 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -247,12 +247,12 @@ if is_variable('serdi')
timeout: 240)
endforeach
- ### The terse suite needs to be run with -t
+ ### The terse suite needs to be run with -o terse
test('terse', run_test_suite,
args: script_args + ['--osyntax', 'turtle',
files('terse/manifest.ttl'),
serd_base + 'terse/',
- '--', '-t'],
+ '--', '-o', 'terse'],
env: test_env,
suite: ['rdf', 'serd'],
timeout: 240)
@@ -260,7 +260,7 @@ if is_variable('serdi')
manifest = files('pattern' / 'manifest.ttl')
base_uri = serd_base + 'pattern' + '/'
test('pattern', run_test_suite,
- args: script_args + [manifest, base_uri, '--', '-x'],
+ args: script_args + [manifest, base_uri, '--', '-i', 'variables'],
env: test_env,
suite: ['rdf', 'serd'],
timeout: 240)
@@ -287,7 +287,8 @@ if is_variable('serdi')
### ... and once with lax parsing to tolerate them
test('lax.lax', run_test_suite,
- args: script_args + [lax_manifest, lax_base_uri, '--', '-l'],
+ args: script_args + [lax_manifest, lax_base_uri, '--',
+ '-i', 'lax', '-o', 'lax'],
env: test_env,
is_parallel: false,
suite: ['rdf', 'serd'],