aboutsummaryrefslogtreecommitdiffstats
path: root/test/pretty/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/pretty/meson.build')
-rw-r--r--test/pretty/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/pretty/meson.build b/test/pretty/meson.build
new file mode 100644
index 00000000..634f1e0e
--- /dev/null
+++ b/test/pretty/meson.build
@@ -0,0 +1,17 @@
+base_uri = 'http://drobilla.net/sw/serd/test/good/'
+
+args = [files('manifest.ttl')]
+
+test('pretty',
+ run_pretty_suite,
+ args: pipe_test_script_args + ['-o', meson.current_build_dir() / 'pipe'] + args,
+ env: test_env,
+ suite: ['suite', 'extra', 'pipe'],
+ timeout: 240)
+
+test('pretty',
+ run_pretty_suite,
+ args: sort_test_script_args + ['-o', meson.current_build_dir() / 'sort'] + args,
+ env: test_env,
+ suite: ['suite', 'extra', 'sort'],
+ timeout: 240)