summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-11-13 11:39:14 -0500
committerDavid Robillard <d@drobilla.net>2024-11-13 11:50:02 -0500
commit35e76431e5bdf24b67dc0b9a3f78367adb36b15c (patch)
tree2b9ad8cd52b1a50db3788be31a6ef20f4ce73359 /meson.build
parent613997e29aff202492ab368768c57857640b23b2 (diff)
downloadsord-35e76431e5bdf24b67dc0b9a3f78367adb36b15c.tar.gz
sord-35e76431e5bdf24b67dc0b9a3f78367adb36b15c.tar.bz2
sord-35e76431e5bdf24b67dc0b9a3f78367adb36b15c.zip
Fix build as C with MSVC
It used to be necessary to build modern C code as C++ with MSVC, but its C support has become more or less serviceable, so remove the flag to force C++ mode and build as C everywhere.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index e4579d2..b1c9023 100644
--- a/meson.build
+++ b/meson.build
@@ -30,11 +30,6 @@ cc = meson.get_compiler('c')
# Set global warning flags
subdir('meson/suppressions')
-# Build as C++ with MSVC
-if cc.get_id() == 'msvc'
- add_project_arguments(['/TP'], language: ['c'])
-endif
-
################
# Dependencies #
################